Ruby

Requirements

Our Ruby agent supports Ruby on Rails 2.2+ and Ruby 1.8.7+. See a list of libraries we auto-instrument.

Memory Bloat detection require Ruby 2.1+.

Scout APM 4.0.0+ requires Ruby 2.1+. If you’re using a Ruby version lower than 2.1, you can still use Scout APM 2.6.10.

Installation

Tailored instructions are provided within our user interface. General instructions:

1. Your Gemfile:

gem 'scout_apm'

Shell:

bundle install

2. Download your customized config file*, placing it at config/scout_apm.yml. Your customized config file is available within your Scout account.

3. Deploy.

Updating

The latest version of scout_apm is SEE CHANGELOG.

1. Ensure your Gemfile entry for Scout is: gem 'scout_apm'

2. Run bundle update scout_apm

3. Re-deploy your application.

The gem version changelog is available here.

Instrumented Libraries

The following libraries are currently instrumented:

Additionally, Scout can also instrument request queuing time.

You can instrument your own code or other libraries via custom instrumentation.